Bug #3521

Problems with project copying

Added by Vadim 3 months ago. Updated about 1 month ago.

Status:ClosedStart date:05/15/2020
Priority:NormalDue date:
Assignee:Vadim% Done:

0%

Category:-
Target version:RapidDeploy - 5.0-FIX
Affects Version:5.0-FIX Additional version details:
Timesheet Code:

Description

Hello.

Found a real problem with projects that are being copied.
Environment:
1. I create a base project. I assign one or several data dictionary resources to that base project, save it, close it. When opening again to check - everything is Ok, just as I configured.
2. I copy base project and name it somehow differently from base one. Lets call it child project. On a first window when project is being copied I can edit project's name only. So I enter it and save. After that all child project's settings are available to be edited. On general tab I see that resources that were assigned to my base project are not assigned to my child project. I should say that's not I expect to have when copying base project.
3. I do not apply any changes to my child project and just save it again. I am informed that some values from data dictionary are removed (those from base project's resources).
4. I still don't apply any changes to child project and just close it. In a project list I select my base project and open it. What I see - no resources are assigned to my base project.

Seems that base and child projects still have some linking between. There are also problems with resource variables. If in child project I leave them be without resource (I don't assign resource to project like it was in base project), variables are still marked as from resource and there are problems with assigning values to them.

Don't think it's "as designed". :)

Please let me know if You need any additional information. I tried this issue with several projects and it's really so as described.

Best regards,
Vadim.

History

#1 Updated by Vadim 3 months ago

In addition:
On the same configuration I added resource to a child project and after saving the same resource appeared in a base project.

#2 Updated by Vadim 3 months ago

Update:
Problem arises because new (copied) project shares the same SCM directory as a base one. And even after project's name is changed SCM directory is not changed automatically.

#3 Updated by Rafael 3 months ago

  • Status changed from New to In Progress
  • Assignee set to Rafael
  • Target version set to 5.0-FIX

#4 Updated by Rafael 3 months ago

  • Assignee changed from Rafael to Mariano
  • Priority changed from Critical to Normal

Hi Vadim,

Once again you've found something tricky in the tool.

As you have indeed already discovered, it is related to the fact you left the same "Project root directory" in the "SCM Repository" tab, so both projects target the same configuration files, meaning if you change something in one project it will be changed in the other one.

This is actually intentionally design like this, there are quite a few scenarios where you would have different projects using the same files and resources but with a different orchestration, that's why you can specify a different orchestration file in the "Orchestration file name" field of the "General" tab.

As you already found out, the simplest solution is just to select a new project path in the "SCM Repository" tab, but there's still an issue about showing the resource in the UI.

If you check the "resources.xml" file in the project root folder, you can see something like this:

<?xml version="1.0" encoding="UTF-8"?>
<resourceList xmlns="http://www.midvision.com/rapiddeploy/domain/xml/resource" xmlns:ns2="http://www.midvision.com/rapiddeploy/domain/xml/resourcelist">
    <ns2:resource name="DataDictionaryResourceTest" resourceType="Local File Library (v5.0.0)">
        <path>/Users/rafaelruizpalacios/mv_home_trunk/resources/DataDictionaryResourceTest.xml</path>
        <packageRelativePath>resources</packageRelativePath>
        <resourceFormat>DICTIONARY</resourceFormat>
        <description/>
        <projectResourceScope projectName="GeneralTest"/>
        <projectResourceScope projectName="GeneralTestCopy"/>
    </ns2:resource>
</resourceList>

And here the problem is we are not updating the "projectResourceScope" reference tag, definitely a bug.

A very simple workaround is to select the necessary resources in the cloned project right after creating it but before you click on "Save" for the first time.

We're going to be working on this today, but as there's a simple workaround for it, I'm going to reduce the priority on the ticket.

Once again, thanks a lot for all your feedback and sorry for any inconvenience! :-)

Cheers!

Rafa

#5 Updated by Vadim 3 months ago

Hi Rafael.

Yes, that's Ok with priority. That just was my first reaction when I realized that cannot copy project. :) After I found a workaround it doesn't seem to be very critical. :)

Best regards,
Vadim.

#6 Updated by Mariano 3 months ago

  • Status changed from In Progress to Marked for Closure
  • Assignee changed from Mariano to Vadim

Hi Vadim,

The copy project issue about resources references was fixed and it will be available on next release 5.0.20.

Regarding the autoupdate of the project root path when the name is changed will be added to the product roadmap to be added soon.

Regards,
MP

#7 Updated by Rafael 3 months ago

  • Assignee changed from Vadim to Rafael

#8 Updated by Rafael 3 months ago

  • Status changed from Marked for Closure to Resolved

#9 Updated by Rafael 2 months ago

  • Status changed from Resolved to Marked for Closure
  • Assignee changed from Rafael to Vadim

Hi Vadim,

RapidDeploy 5.0.20 is already out with a fix for this, please feel free to close this ticket if you're happy with it or we will just time it out in a few days time.

Cheers!

Rafa

#10 Updated by Rafael about 1 month ago

  • Status changed from Marked for Closure to Closed

Also available in: Atom PDF