Image Support #3472

How to patch instance launched from Midvisiion AMI

Added by Thushara 3 months ago. Updated 25 days ago.

Status:ClosedDue date:
Priority:Normal% Done:

0%

Assignee:Thushara
Category:-
Image:WebSphere MQ 9.1 Your Marketplace Account ID:8332-8048-3659
Operating System:RHEL 7.5 Marketplace:Amazon Web Services
JRE:v1.8 JRE/JDK 64-Bit Customer State:Haryana
Instance Type:Not Listed Customer Country:India

Description

How do we perform patching for the instancelaunched from AMI:AwsMarketPublished_WebSphere MQ v9.1.0.3 Standard Edition and Rapid-3fc26a5a-315e-4b0b-a166-c78644c8c521-ami-0e3aab8aa2820c318.4 (ami-0aa58868cbc2b157e)?

Current version is RHEL 7.7.Will normal working of MQ be affected after we patch the instance? Also is there any automation available for patching using rapiddeploy?

UpgradeMQ.zip (7.9 KB) Mariusz, 04/20/2020 03:07 pm

Upgrading IBM MQ with Rapiddeploy - instruction.txt Magnifier (1.19 KB) Mariusz, 04/20/2020 03:07 pm

error.PNG (33.4 KB) Thushara, 04/22/2020 01:27 pm

History

#1 Updated by Mariusz 3 months ago

  • Status changed from New to Feedback
  • Assignee set to Thushara

Hi,
If I understand correctly you would like to upgrade RHEL to version 8. Am I right?

After patching the instance we will still be supporting the IBM MQ installation, so there is no problem with that.
It is possible to automate patching using rapiddeploy. If you would like to try it I can prepare a project with the instruction for you or we can schedule a call so I can show you how it can be done.

I guess we will need to automate the steps from this documentation: https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html-single/upgrading_to_rhel_8/index

Could you take a look and confirm that this is exactly what you expect?

Kind regards,
Mariusz

#2 Updated by Thushara 3 months ago

Hi Mariusz,

Going through the link you have shared, i could see that Upgrade from RHEL 7.7 and later versions is not supported .Currently the os version is rhel 7.7.

cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.7 (Maipo)

In our project,we follow a quarterly patching schedule where we give yum update and reboot the server.
So i wanted to know the procedure we have to follow for this particular server.If u could please share a documentation with the instructions,it will be helpful for us.

Also i could see that server is not subscribed.Kindly include the steps for doing this also, if it is necessary for patching.

subscription-manager list --installed
-----------------------------------------
Installed Product Status
-----------------------------------------
Product Name: Red Hat Enterprise Linux Server
Product ID: 69
Version: 7.8
Arch: x86_64
Status: Unknown
Status Details:
Starts:
Ends:

#3 Updated by Mariusz 3 months ago

Hi,

Thank you for clarification. I think I misunderstood what was your original question.

So there is no problem with running yum update to upgrade your OS regularly. It will not affect IBM MQ installation and we will still provide support after upgrading to newer version. I don't think you will need any specific procedure for this. You can just use yum update and then restart the server. Just remember that the public IP will change if you don't have elastic IP configured for your instance, so we usually suggest to use elastic IPs to avoid any unexpected problems.
Also remember to restart queue managers when you restart the instance.

You don't have to subscribe to RedHat to get access to OS updates. Red Hat Enterprise Linux instances will have access to the regional repositories to receive incremental updates and is included in all prices. Our IBM MQ installation is based on RHEL instance from AWS.
You can get more info from https://aws.amazon.com/partners/redhat/faqs/

Thanks,
Mariusz

#4 Updated by Thushara 3 months ago

Hi Mariusz,

I would like to know how the MQ patching is going to be handled by Midvision.

#5 Updated by Mariusz 3 months ago

Hi,

We don't have access to your instance so in general MQ patching cannot be handled by MidVision, but of course we can help you to upgrade your instance in different ways.

1. If your MQ configuration can be easily migrated to the new MQ instance - you can just launch a new version from https://aws.amazon.com/marketplace/pp/B07GXX65ZD?qid=1587119612960&sr=0-4&ref_=srh_res_product_title
2. If you would like to keep using your existing instance then you have three options:
- You can use RapidDeploy to patch your instances. We can give you some instruction how to create project in RapidDeploy and perform and upgrade.
- You can handle the patching by yourself
- You can ask us to perform the patch or migration, which we offer as a consultancy engagement. In this case we will need to shedule a call to discuss all conditions.

Please take a look at this page https://www.midvisioncloud.com/questions/ where you can find more useful information.

#6 Updated by Thushara 3 months ago

Can you please explain regarding the services of consultancy engagement . Would it require additional cost?

While going through the link you shared , saw an option to launch a new MidVision instance at the later patch level and migrate configuration using the RapidDeploy tool included in the image.I want to know a little bit more about this .

#7 Updated by Mariusz 3 months ago

Hi,

It is possible to migrate configuration using the RapidDeploy, although at the moment we don't have generic project which suits all IBM MQ users.
You will need to prepare a RapidDeploy project which will basically follow these steps: https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_9.1.0/com.ibm.mq.con.doc/q018580_.htm

I think in your case it is actually easier and safer to upgrade MQ version rather than migrate configuration to a new instance.
As I mentioned in my previous comment, what I can do is to send you a sample project and description which can help you upgrade IBM MQ using RapidDeploy by yourself. Let me gather this information and send it to you as soon as possible.

When it comes to the services of consultancy engagement - please take a look at this page where everything is described: https://www.midvisioncloud.com/support-services/consultancy-services/

Just one thing to confirm - do you have access to IBM Fix Central to download the fixpack?

Regards,
Mariusz

#8 Updated by Thushara 3 months ago

Hi Mariusz,

We dont have access to IBM Fix Central as of now. We will try to create a new account soon.

As discussed , kindly share us sample project to upgrade IBM MQ using rapiddeploy. Please inform me if you want any other details from my side.

#9 Updated by Mariusz 3 months ago

Hi,

I am attaching the project which will help you to upgrade your instance to the newest version which is 9.1.0.5.
Remember

Before you use it I suggest you to see the tutorials for RapidDeploy to know the main concepts and understand how it works.
https://www.midvision.com/webcasts-videos/

Then when you are ready to upgrade - if you decide to do it using RapidDeploy - we are happy to schedule a call and assist you (with no charge) and show you what exactly is happening, how exactly RapidDeploy upgrades your instance etc.
Of course if you feel confident to do it yourself - it is perfectly fine as well. Just remember to create a backup of your instance properly.

Kind Regards,
Mariusz Chwalek

#10 Updated by Thushara 3 months ago

Hi Mariusz,

Thank you so much for sharing the documents . While trying to access the rapidDeployconsole we got error saying Invalid Software License. Attaching screeshot of the error.Kindly advise on how to proceed.

#11 Updated by Rafael 3 months ago

Hi Thushara,

We provide a default 3 months license with our AMIs, and your instance is probably older than 3 months, so the license must have expired.

The best approach we recommend for this is to download the newest RapidDeploy, which will have the newest fixes and features, and will come with a new default 3 months license.

To download RapidDeploy please use this link:

https://www.midvision.com/rapiddeploy-how-to-guides/download-rapiddeploy-2/

Once you have it, stop the current RapidDeploy service in the server:

sudo service rapiddeploystart stop

Then move the current RapidDeploy home folder to a backup location:

mv /var/rd/midvision /var/rd/midvision_backup

And then unzip the just downloaded RapidDeploy package into the same path:

unzip midvision-rapiddeploy-package-lnx64.zip -d /var/rd/

Then just start the service again:

sudo service rapiddeploystart start 

And it should do the work! :-)

Let me know if you find any problem or need further assistance!

Cheers!

Rafa

#12 Updated by Rafael 2 months ago

  • Status changed from Feedback to Marked for Closure

Hi Thushara,

We noticed there hasn't been an update to this ticket for some time. Can we consider this ticket closed from support point of view? Is this still an issue or is there anything further that we can do for you in this regard? If not we will be timing out this ticket and will be closed in a few days time. If you have any other queries, please do not hesitate to ask us.

Cheers!

Rafa

#13 Updated by Rafael about 1 month ago

  • Status changed from Marked for Closure to Closed

#14 Updated by Thushara about 1 month ago

Hi,

Sorry for the late update..we tried running the steps as you have provided for updating MQ.The instance is part of autoscaling group in AWS which uses EFS for storage, so when queue manager is down a new instance will be launched. I forgot to give protection termination,so a new instance got launched during the patch time. Since i had taken an AMI before patch, i launched new server from that and it was working fine for 1 hr. After that queue manager went to Ended preemptively state..and we tried launching new server from another ami also with same result. So we presume that EFS got corrupted.

Could you please arrange a session for us and show us the process live in our instance.It will be so much helpful.

#15 Updated by Richard about 1 month ago

  • Status changed from Closed to Feedback

#16 Updated by Mariusz about 1 month ago

Hi Thushara,

Sorry to hear that the upgrade didn't go very well. As I mentioned When you upgrade MQ there shouldn't be any running Queue Managers on the instance you upgrade.
In this case we can still arrange a session to show you how RapidDeploy does the upgrade (on the instance where no QM is running) but when it comes to corrupted EFS or any investigation regarding your current MQ installation - it will be a consultancy and you will need to fill this form first to request MQ expert: https://www.midvisioncloud.com/request-consultancy-services/

Kind regards,
Mariusz Chwalek

#17 Updated by Mariusz about 1 month ago

  • Status changed from Feedback to Marked for Closure

Hi,
We noticed there hasn't been an update to this ticket for some time. Can we consider this ticket closed from support point of view? Is this still an issue or is there anything further that we can do for you in this regard? If not we will be timing out this ticket and will be closed in a few days time. If you have any other queries, please do not hesitate to ask us.
Thanks,
Mariusz

#18 Updated by Thushara about 1 month ago

Hi,

We would like to have a session for MQ patch using rapiddeploy . Could you please arrange this for tomorrow at 4.00 PM IST? or else please propose any alternate timings.

#19 Updated by Mariusz about 1 month ago

Hi,
I will send you the invitation in a separate email.
Thanks,
Mariusz Chwalek

#20 Updated by Mariusz about 1 month ago

  • Status changed from Marked for Closure to In Progress

I noticed we don't have your email so I am sharing meeting invitation here:

Mariusz Chwalek is inviting you to a scheduled Zoom meeting.

Topic: IBM MQ upgrade using RapidDeploy
Time: Jun 9, 2020 11:30 AM London

Join Zoom Meeting
https://us02web.zoom.us/j/84273894602

Meeting ID: 842 7389 4602
One tap mobile
+16465588656,,84273894602# US (New York)
+16699006833,,84273894602# US (San Jose)

Dial by your location
+1 646 558 8656 US (New York)
+1 669 900 6833 US (San Jose)
+1 253 215 8782 US (Tacoma)
+1 301 715 8592 US (Germantown)
+1 312 626 6799 US (Chicago)
+1 346 248 7799 US (Houston)
+44 203 481 5237 United Kingdom
+44 203 481 5240 United Kingdom
+44 131 460 1196 United Kingdom
+44 203 051 2874 United Kingdom
+54 341 512 2188 Argentina
+54 343 414 5986 Argentina
+54 112 040 0447 Argentina
+48 22 307 3488 Poland
+48 22 398 7356 Poland
+34 91 787 0058 Spain
+34 917 873 431 Spain
+34 84 368 5025 Spain
Meeting ID: 842 7389 4602
Find your local number: https://us02web.zoom.us/u/koMsSIgXA

#21 Updated by Thushara about 1 month ago

Hi ,

Thanks for the session today.

Could you please update us regarding extending the license for rapideploy.

#22 Updated by MidVision about 1 month ago

Hi Thushara,

You can request a new license here: [[https://www.midvision.com/support-services/request-a-rapiddeploy-license/]]

License for up to 10 nodes is free and issued for 1 year at a time (it is free forever but you need to request a license annually).

Best Regards.

#23 Updated by Thushara about 1 month ago

Hi,

We have successfully upgraded the MQ version from 9.1.0.3 to 9.1.0.5.

I have a query regarding certificate. Since our server is part of autoscaling group and if autoscaling actions occurs 10 times,each time launching a new server with same hostname but different ip.Will these be considered as 10 endpoints and the license wont work for the 11th instance?

#24 Updated by Rafael about 1 month ago

  • Status changed from In Progress to Marked for Closure

Hi Thushara,

I'm glad you got your IBM MQ upgraded! :-)

Regarding the RapidDeploy licensing, you have more information here:

https://www.midvision.com/rapiddeploy-pricing/

You can essentially target 10 different hostnames or IP addresses.

This is a very particular case, as the number of targets you need can vary depending on the autoscaling needs, but you can try targeting the single hostname you have from RapidDeploy and checking how it reacts in this particular scenario, as long as the credentials to connect to every server are the same.

If you happen to have just a few instances over 10 we can study some options, but initially over 10 endpoints you will need a different licensing, and thus a quote from us.

Let us know if you have any other query regarding this case, otherwise I'll time it out in a few days time.

Cheers!

Rafa

#25 Updated by Rafael 25 days ago

  • Status changed from Marked for Closure to Closed

Also available in: Atom PDF