Image Support #3271

About MQ

Added by sachiko 5 months ago. Updated 3 months ago.

Status:ClosedDue date:02/15/2019
Priority:High% Done:

0%

Assignee:sachiko
Category:-
Image:WebSphere MQ 9.1 Your Marketplace Account ID:0163-5506-6488
Operating System:Any Marketplace:Amazon Web Services
JRE:Any Customer State:Tokyo
Instance Type:All Customer Country:JAPAN

Description

Dear Support desk,

①Has the contents of the header been rewritten by setting change of the MQ server?
② When the contents of the header are rewritten, what is the case
③ If there is a way to undo after the contents of the header change, please tell me

Regards,
sachiko

MQ configuration.pptx (38.8 KB) sachiko, 02/15/2019 05:40 am

History

#1 Updated by Mariusz 5 months ago

  • Status changed from New to Feedback

Hi Sachiko,
I can see you created a new ticket with the same content from #3269.
We are happy to help you but we need more information.
We don't understand what exactly you are trying to configure?
What do you mean by "rewriting contents of the header"? Do you mean the header of the message which is sent from java app to MQ Server?
If yes, could you possibly describe step by step - what exactly you have done already.

You can reply directly to IBM Support as they also wait for more information.

Kind Regards,
Mariusz

#2 Updated by sachiko 5 months ago

Dear Support desk,

「Rewriting the contents of the header」 is not the header of the message sent from the Java application to the MQ server.

Please see the attached figure.
It is the part that sends a message from MQ to the stub. (I'm surrounded by a red frame.)
When extracting a file from MQ, is the content of the message header rewritten?
Please tell me whether the message header may be rewritten at this point due to setting change etc.
Thanks

Regards,
sachiko

#3 Updated by Mariusz 5 months ago

Hi Sachiko,
Have you seen the reply from IBM Support?
Does this part help to solve your problem?

You state the problem started after making a local queue an
    alias queue. If you created a new queue, you will want to
    compare the queue definitions for any differences, specifially
    PROPCTL which can add/remove MQRFH2 headers. I've included
    some information below about MQRFH2 headers.

The queue manager can alter the mqmd header to include or remove
   MQRFH2 headers. The PROPCNTL parameter on the queue and possibly
   SDR channel controls this behavior, but at this time it's not
   clear if this is the problem. This can be changed on producing
   or consuming queues, channels and by the application.    

    If so, see related links below for more information on PROPCNTL
    and ways within the application.

    If not, please supply more details about the problem headers.

I've included several links below relating to MQRFH2 headers in case
this is related to the problem.

PROPCTL queue options
https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_9.0.0/
com.ibm.mq.ref.dev.doc/q008230_.htm

Destination property WMQ_MESSAGE_BODY
https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_9.0.0/
com.ibm.mq.dev.doc/q032370_.htm

Overview for MQRFH2
https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_9.0.0/
com.ibm.mq.ref.dev.doc/q099250_.htm

Properties specified as MQRFH2 elements
https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_9.0.0/
com.ibm.mq.ref.dev.doc/q104130_.htm

If the problem is not related to MQRFH2 headers, we
will need the following information to further define
the problem and start with root cause.

1. The versions of the local and remoate MQ clients
   and all MQ servers in the message flow.

2. A copy of the application log reporting the error.

3. A copy of the mq server qmgr error log reporting the error.

4. What specific change did you make resulting to this problem ?
   Upgrade MQ server / client ? Alter queue definitions, if so
   supply runmqsc display channel defs of the queues in
   quest before / after the change

5. Did this work before implementing the above changes or is
   this a new setup ?

If the supplied MQRFH2 information does not apply here
then please respond to the above question and supply the
requested documentation further defining the problem allow
us to proceed with root cause.

Thanks and Kind Regards,
Drew Daly

#4 Updated by sachiko 5 months ago

I'm sorry.
Is there a specification that can rewrite the contents of the message header when extracting a file from MQ?
Please answer yes or no.
If yes,
If the contents of the header were to be rewritten, what is the case?
If you have a way to undo after the contents of the header has changed, please let me know.

Thank you

#5 Updated by sachiko 5 months ago

I fixed the question just before.
Please reply to me.

Is there a specification that the content of the message header changes when extracting files from MQ?
Please answer with yes or no.
If yes,
If the contents of the header were to be rewritten, what is the case?
If you have a way to undo after the contents of the header has changed, please let me know.

Thank you

#6 Updated by sachiko 5 months ago

Is there a specification that the content of the message header changes when extracting files from MQ?
Please answer with yes or no.
If yes,
If the contents of the header were to be rewritten, what is the case?
If you have a way to undo after the contents of the header has changed, please let me know.

Thank you

#7 Updated by Mariusz 5 months ago

Hi Sachiko,

Are you receiving emails from IBM Support? Could you please read the suggestions from there and see if is helpful in your case?

When it comes to your last questions:
As you can see I added them to the email thread and we are waiting for the reply from IBM Support.
If you would like to add something more -please just reply to the email from IBM Support.

Regards,
Mariusz

#8 Updated by sachiko 5 months ago

Additionally let me clarify the following points.

①How can we know whether "message MQMD is message_reply generated by target"?

②We are using the MQ V6 Java client as MQ client. The contents of the header has been changed unexpectedly when we send the queue to stab, right?
If so, what's the reason of this behavior?

Thank you.

※I replied to IBM support, but because I could not send it, please cooperate.Thank you.

#9 Updated by Mariusz 5 months ago

  • Assignee changed from sachiko to IBM Support

Hi Sachiko,
I can see IBM support received your message today.
Let's wait for the reply.

Regards,
Mariusz

#10 Updated by Mariusz 5 months ago

  • Assignee changed from IBM Support to sachiko

Just to keep track on the progress I am adding the reply from IBM Support:

Hello Sachiko and Mariusz,

Thank you for your additional questions below. I have responded to your questions by supplying
you with links to information documenting all the changes to the mq java client back to V7.1-7.5. As you will
see there have been many changes with mq java client since V6 that could be related to your problem.
Therefore I have also included my recommendation to advance root cause with ths V6 unsupported client.
Let me know if you have any questions regarding my recommendation.

Additionally let me clarify the following points.

1. How can we know whether "message MQMD is message_reply generated by target"?

A. You can either print or browse the message from the local reply_queue to
see the full MQMD and message content. It will included the full MQMD created
by the remote target application. See the links below for more information
about handling the message headers and content.

Browsing queues
https://www.ibm.com/support/knowledgecenter/SSFKSJ_9.0.0/com.ibm.mq.adm.doc
/q020800_.htm

Printing all the headers in a message using IBM® MQ classes for Java
https://www.ibm.com/support/knowledgecenter/SSFKSJ_9.0.0/com.ibm.mq.dev.doc
/q030890_.htm

Handling IBM MQ message headers with IBM MQ classes for Java
https://www.ibm.com/support/knowledgecenter/SSFKSJ_9.0.0/com.ibm.mq.dev.doc
/q030880_.htm

2. We are using the MQ V6 Java client as MQ client. The contents of the header
has been changed unexpectedly when we send the queue to stub, right?

  If so, what's the reason of this behavior?

A. The above information will allow you to review the message before it's
   consumed by the application allowing you to identify what has changed
   in the message header from when the working case.

   There has been changes since MQ V6 which are documented
   in the "What's Changed" section of each version's knowledge center
   several of which I included below for your reference and review.

   https://www.ibm.com/support/knowledgecenter/SSFKSJ_8.0.0/com.ibm.mq.pro.doc
   /q001060_.htm

   https://www.ibm.com/support/knowledgecenter/SSFKSJ_7.5.0/com.ibm.mq.pro.doc
   /q001060_.htm

   https://www.ibm.com/support/knowledgecenter/SSFKSJ_9.0.0/com.ibm.mq.pro.doc
   /q001060_.htm

   https://www.ibm.com/support/knowledgecenter/SSFKSJ_9.0.0/com.ibm.mq.pro.doc
   /q001060_.htm

   https://www.ibm.com/support/knowledgecenter/SSFKSJ_9.1.0/com.ibm.mq.pro.doc
   /q001060_.htm

   MQ V6, 7.0, 7.1, 7.5 clients are out-of-support, as previously noted,
   so it is recommended to upgrade to a supported version using a
   link below.

   MQC8: IBM MQ V8 Clients
   http://www-01.ibm.com/support/docview.wss?uid=swg24037500

   MQC9: IBM MQ V9 Clients
   https://www-01.ibm.com/support/docview.wss?uid=swg24042176

To proceed and progress root cause of this problem, I suggest the following
recommendations.

1. Use the supplied links to print or browse the message
header of a working and failing message to identify any changes.
While this may allow you to identify the change affecting the V6 java
client, it would like require the mq v6 client be upgraded to fix it,
so it's recommended to upgrade to a supported version.

2. Review the "What's changed" section of the last working mq server's
knowledge center through the mq server running today to identify
changes that apply the the mq v6 java client.

3. Upgrade the mq v6 java client to a supported version using
   the supplied links then implement the above documented changes
   that apply to the mq java client.

If you continue to have a problem after follow the above steps,
we would need matching mq java client and mq server traces
and problem logs along with the mq client ip address, source and
target queue names and the full message flow from source to target
applications.

Please let us know if you have any questions regarding the above
action plan.

Thanks and Kind Regards,
Drew Daly
IBM MQ Support.

#11 Updated by Mariusz 5 months ago

Received from IBM Support:

Hello Sachiko and Mariusz,

I've not received any updates or fup questions to my email Q/A below, please let me know
if you have any other questions.

#12 Updated by Mariusz 5 months ago

  • Status changed from Feedback to Marked for Closure

Received from IBM:

Hello Sachiko and Mariusz,

I've not received any updates or fup questions to my email Q/A below, please let me know
if you have any other questions and your plans to proceed with suggested recommendation.
If you have no fup questions over the next week, I will temporarily close the call which can be
reopened within 28 business days.

Can we consider this ticket closed from support point of view? Is this still an issue or is there anything further that we can do for you in this regard? If not we will be timing out this ticket and will be closed in a few days time. If you have any other queries, please do not hesitate to ask us.

Regards,
Mariusz

#13 Updated by sachiko 5 months ago

Dear Support desk,
The amqsbcg command can not be used.
Why?

please tell me
Thank you.
Regards,
sachiko

#14 Updated by Mariusz 5 months ago

  • Status changed from Marked for Closure to Feedback

Hi Sachiko,

I can see that IBM Support didn't reply to your question yet. I think the reason is that you didn't reply whether you tried their suggestions and whether you followed the steps they asked you to do.
Their last message is:

To proceed and progress root cause of this problem, I suggest the following
recommendations.

1. Use the supplied links to print or browse the message
header of a working and failing message to identify any changes.
While this may allow you to identify the change affecting the V6 java
client, it would like require the mq v6 client be upgraded to fix it,
so it's recommended to upgrade to a supported version.

2. Review the "What's changed" section of the last working mq server's
knowledge center through the mq server running today to identify
changes that apply the the mq v6 java client.

3. Upgrade the mq v6 java client to a supported version using
   the supplied links then implement the above documented changes
   that apply to the mq java client.

If you continue to have a problem after follow the above steps,
we would need matching mq java client and mq server traces
and problem logs along with the mq client ip address, source and
target queue names and the full message flow from source to target
applications.

Please let us know if you have any questions regarding the above
action plan.

1. Did you use the supplied links to print or browse the message
header of a working and failing message to identify any changes?
2. Did you upgrade mq v6 client to a supported version?

Kind Regards,
Mariusz Chwalek

#15 Updated by sachiko 4 months ago

Dear Support desk,

1. Checking.
Messages that are not working properly
I want to print or reference a header using the amqsbcg command.
2. I have not upgraded yet.

Thank you.

Regards,
sachiko

#16 Updated by Mariusz 4 months ago

Hi Sachiko,
Command not found means that the PATH does not include the directory where amqsbcg resides.
Use the find command to locate amqsbcg. Then change directory (cd) to that directory, then execute the amqsbcg command.
You should be able to see this result:

[root@ip-172-31-11-20 mqm]# find / -name "amqsbcg" 
/opt/mqm/samp/bin/amqsbcg

Regards,
Mariusz Chwalek

#17 Updated by sachiko 4 months ago

Dear Support desk,

I have two questions.

① The version of MQ server being used is IBM MQ 9.0.3.0.
What version of MQClient and Java are recommended for this MQ server?

② Change the version of the MQ client.
Is there a list of recommended combinations of MQ server, MQ client, Java version?
If there is information, please.

Thank you.

Regards,
sachiko

#18 Updated by Mariusz 4 months ago

  • Marketplace changed from Amazon Web Services + Microsoft Azure to Amazon Web Services

Hi Sachiko,

I am afraid IBM already closed this PMR as you haven't replied to them for some time.
I asked them to open this ticket.
I added you to the email thread so you will be informed as soon as they reply something.

In the meantime - I think you can find more information about the compatibility on IBM MQ requirements page:
http://www-01.ibm.com/support/docview.wss?uid=swg27006467

Kind Regards,
Mariusz Chwalek

#19 Updated by sachiko 4 months ago

Dear Support desk,

Hurry and want information.
About when will that be?

Thank you.

Regards,
sachiko

#20 Updated by Mariusz 4 months ago

Hi Sachiko,
Did you take a look at the IBM documentation page I shared with you in my last comment? I think you can find all the information there.

1. For MQ v9 :
JAVA:
Oracle Java SDK/JRE/JDK : 7.0.45 and higher (including v8) - v8 is recommended
IBM Runtime Environment, Java Technology Edition : 7.0.6 and higher - v8 is recommended

MQ Client:
v8.0, v9.0, v9.1

2.
I am not aware of a list with recommended combinations. IBM always suggests that it is a best practice to use the latest fix pack for each of the versions that you are using.
http://www-01.ibm.com/support/docview.wss?uid=swg21312967

Regards,
Mariusz Chwalek

#21 Updated by Rafael 3 months ago

  • Status changed from Feedback to Marked for Closure

Hi Sachiko,

We noticed there hasn't been an update to this ticket for some time. Can we consider this ticket closed from support point of view? Is this still an issue or is there anything further that we can do for you in this regard? If not we will be timing out this ticket and will be closed in a few days time. If you have any other queries, please do not hesitate to ask us.

Best regards,

Rafa

#22 Updated by Rafael 3 months ago

  • Status changed from Marked for Closure to Closed

Also available in: Atom PDF