Image Support #3269

IBM WebSphere MQ and MQ Advanced on AWS

Added by sachiko over 1 year ago. Updated over 1 year ago.

Status:ClosedDue date:02/13/2019
Priority:High% Done:

0%

Assignee:IBM Support
Category:-
Image:WebSphere MQ 9.1 Your Marketplace Account ID:0163-5506-6488
Operating System:Any Marketplace:Amazon Web Services + Microsoft Azure
JRE:Any Customer State:Tokyo
Instance Type:All Customer Country:JAPAN

Description

Dear Support desk,

Related tickets #3258

Could you give us the advise for following issue of the MQ Client?

<Issue Overview>
When we set the alias queue in the exsiting local queue, we are getting the attached error message as the message from the alias queue is different from the subordinate.

<Environment>
MQ client: WebSphere MQ Client for Java 6.0.0

<Confirmation Point>
Could you confirm for following poits?
- The reason of this issue that we cannot receive the expected message.
- The resolution to avoid this issue.

If you need more specific information for your investigation, please let me know.
Thank you.

Regards,
sachiko

スタブ実行結果_20190205.xlsx (299 KB) sachiko, 02/12/2019 09:43 am

History

#1 Updated by Mariusz over 1 year ago

  • Status changed from New to Feedback

Hi Sachiko,

Thank you for updating the AWS Marketplace Account ID.
I can see that there are two tickets for the same issue #3258 and #3269. We will close the old one to avoid the confusion.
As we mentioned https://support.midvision.com/redmine/issues/3258#note-3 we also would like to ask you for the translation of the spreadsheet. We are not able to understand the logs.

Kind Regards,
Mariusz Chwalek

#2 Updated by Mariusz over 1 year ago

HI Sachiko,
We also would like to collect more information:
1. Has this ever worked ? and if it has when did it start Failing ?
2. Could you describe in details how we can reproduce the problem? What are exactly the steps you took to get this error?
3. Please send us a runmqras with the defs option specified from the MQ instance covering the time the error happens.
Follow this link and collect IBM MQ MustGather data so we can investigate the problem.
https://www-01.ibm.com/support/docview.wss?uid=swg21290340

Kind Regards,
Mariusz Chwalek

#3 Updated by Mariusz over 1 year ago

Hi Sachiko,
We also would like to get information about:
1. The name of the local queue and the name of the alias queue

2. What are the error messages or return codes or unexpected behavior that you are seeing?

3. What is the full version/fixpack level of MQ? You can use the command: dspmqver
3.a) For the MQ queue manager?
3.b) For the MQ Client application? (in case that the application is running in a different host)

4. From the host that has the queue manager, could you please run the MQ tool "runmqras" which sends to us the MQ error log files, FDC files? We suspect that there might be relevant information in these files and we would like to get a copy of them.
The tool "runmqras" will gather the files (such as error logs) and information for troubleshooting into a zip file and will use ftp to send us the zip file.
The following command has been customized for your PMR.
Please replace QMgrName for the name of your queue manager in the following command:

   runmqras -qmlist QMgrName -section defs -pmrno 80496,999,866 -ftp IBM

Kind Regards,
Mariusz Chwalek

#4 Updated by sachiko over 1 year ago

Dear Support desk,

I'm sorry. My question was wrong.
There are three things you would like me to tell you the first time since I will send you 7 items of information that I am asking for later.
① As for my question, the content of the header may be rewritten by the MQ server setting change.
② If the contents of the header were to be rewritten, what is the case?
③ If you have a way to undo after the contents of the header has changed, please let me know.
Thank you.

Regards,
sachiko

#5 Updated by Mariusz over 1 year ago

  • Assignee changed from sachiko to Mariusz

#6 Updated by Mariusz over 1 year ago

  • Assignee changed from Mariusz to IBM Support

Hi Sachiko,
I added you to my email to the IBM support. As I mentioned there I think it will be the best and the fastest way to resolve this problem.

I will be updating the ticket regularly with the latest status.

Regards,
Mariusz

#7 Updated by Mariusz over 1 year ago

  • Status changed from Feedback to Closed

This ticket will be closed as duplicated. (#3271)

Also available in: Atom PDF