Project

General

Profile

Image Support #3820

Caso de Invocación a Subproceso con Culminación más de una Vez

Added by Jose 2 months ago. Updated 13 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Due date:
% Done:

0%

Operating System:
Linux
JRE:
Not Applicable
Instance Type:
Not Listed
Your Marketplace Account ID:
l-9fc65ba49ffa4ba390e4d97ee0a0ffdd
Marketplace:
Amazon Web Services
Customer State:
Panama
Customer Country:
Panama

Description

Se nos presenta un fallo en la instanciación de un subproceso reutilizable. El motor de procesos completó 2 veces el subproceso, y por consiguiente se generan 2 escenarios de ejecución para la instancia. El comportamiento del resto del proceso se realizó sin problemas, según lo esperado.


Files

PruebaProcesoReutilizableRHPAM.docx (1.47 MB) PruebaProcesoReutilizableRHPAM.docx Jose, 07/12/2021 03:34 PM
Parent_Process.bpmn (17.1 KB) Parent_Process.bpmn Jose, 07/14/2021 12:58 PM
SubProcess.bpmn (12.7 KB) SubProcess.bpmn Jose, 07/14/2021 12:58 PM
#1

Updated by Mariusz 2 months ago

  • Status changed from New to In Progress
  • Assignee set to Mariusz
#2

Updated by Mariusz 2 months ago

  • Assignee changed from Mariusz to Red Hat Support
#3

Updated by Mariusz 2 months ago

  • Status changed from In Progress to Feedback
  • Assignee changed from Red Hat Support to Jose

Hola,

Gracias por contactar con el Soporte Técnico de Red Hat.

Gracias por proporcionarnos la descripción del problema. Pasaremos a testearlo en nuestro entorno y volveremos con nuestras observaciones.

Entendemos que su idioma de preferencia para casos de Soporte Red Hat es el español, y comprendemos el valor y la facilidad de explicar su problema técnico en su idioma de origen.

Sin embargo, a fin de priorizar su caso y de asegurar una resolución más rápida y efectiva, contamos con un grupo más amplio de técnicos angloparlantes que podrán ayudarle utilizando el inglés como idioma en el caso. Teniendo en cuenta esto, ¿Podemos continuar el caso en Inglés?

Déjenos saber su preferencia y desde ya le agradecemos haberse contactado con el Soporte Técnico de Red Hat.

Saludos cordiales,
Oscar
Red Hat Support Team

#4

Updated by Mariusz 2 months ago

Hola,

¿Podríais adjuntar los 2 procesos (Proceso Padre y SubProceso) para testear el comportamiento en nuestro entorno, por favor? La idea es poder reproducir el problema y comprobar las propiedades configuradas de los diferentes componentes.

Por otro lado, recordad confirmarnos si es posible continuar el caso en inglés.

Saludos cordiales,
Oscar
Red Hat Support Team

#5

Updated by Mariusz 2 months ago

Que tal,

Espero que se encuentre bien.

Sí, continuemos en Inglés.

Saludos

Hi,

Thanks for your update. Could you attach the processes (Parent Process and SubProcess) for checking in our environment, please? We would like to reproduce the issue. We tried to reproduce your issue in our environment based on your document but we couldn't.

Thanks in advance.

Best Regards,
Oscar
Red Hat Support Team

#6

Updated by Jose 2 months ago

Hi, I hope you are well.

I have attached the parent process and subprocess for your test.

Best regards

#7

Updated by Mariusz 2 months ago

  • Status changed from Feedback to In Progress
  • Assignee changed from Jose to Red Hat Support
#8

Updated by Mariusz 2 months ago

  • Status changed from In Progress to Feedback
  • Assignee changed from Red Hat Support to Jose

Hi,

Apologies for the delay in getting back to you.

Finally we could reproduce the issue and we have created the JIRA RHPAM-3796 [1]. Our engineering team is working on it. What is the urgency of the resolution of this issue? If there is a fix, it will be included in a later release. Will you need to backport the fix if it is possible?

Thanks in advance.

[1] https://issues.redhat.com/browse/RHPAM-3796

Best Regards,
Oscar
Red Hat Support Team

#9

Updated by Jose 2 months ago

Please the resolution of this issue is very urgent!!!

We need to fix this right now because the project is about to go into production.

#10

Updated by MidVision 2 months ago

  • Assignee changed from Jose to Mariusz
#11

Updated by Jose 2 months ago

Hi, I hope you are well.

Any advance with the fix of this bug?

Best regards

#12

Updated by Jose 2 months ago

Hi Midvision team,

Do you know whats is the SLA with Red Hat team for theses types of issues?

Best regards,

#13

Updated by Rafael 2 months ago

  • Assignee changed from Mariusz to Red Hat Support

Hola, Óscar:

I apologise for this delay, we are depending on the Red Hat team to resolve this.

I've just contacted the Red Hat support team again to increase the priority of this case.

I'll keep you updated with any news we get.

¡Saludos!

Rafa

#14

Updated by Rafael 2 months ago

Sorry, I meant to say "Hola, Jose", not "Hola, Óscar", "Óscar" is the engineer from the Red Hat team working on this case.

#15

Updated by Jose 2 months ago

Hi Rafael,

What is the SLA that you have with Red Hat for theses cases?

#16

Updated by Rafael 2 months ago

Hola, Jose:

This is the answer I had from Red Hat yesterday:

Hi Rafael,

Thank you for the update. We'll inform the engaged team about your current concern. The issue has been tracked in the JIRA case RHPAM-3796, over the week Business hours, the team could provide you more details about it.

Regards,
Alexander

Apparently they are just referencing the Jira case described here:

https://issues.redhat.com/browse/RHPAM-3796

The SLA we have with Red Hat is part of our deal with them, the SLA that is applicable in this case is the one described in the following link:

https://www.midvisioncloud.com/support-services/support-slas

I've already asked for a hotfix if possible, we're doing our best to resolve this issue, I'll keep you posted with any update.

¡Saludos!

Rafa

#17

Updated by Rafael 2 months ago

Hola, Jose:

Here's an answer we got from Red Hat:

Hi Rafa:

We will check with internal engineering team to see if they have any concrete plan on how to fix this and when to release the fix.
Is this issue having any major impact to your client's production system ? i.e. causing production down, or affecting their normal business operation ?

Thanks.

Best Regards,

Lyle Wang
Principal Technical Support Engineer | Team Lead
Cloud Native Development Support, Technical Support Delivery
Customer Experience and Engagement (CEE)
Red Hat Asia-Pacific, Level 1, 193 North Quay, Brisbane, Australia, 4000

¡Saludos!

Rafa

#18

Updated by Jose 2 months ago

Hi Rafael,

Thank you for the advance with this case.

It's a major impact for us because this issue is a stopper for the release of the project in production.

Best regards,

#19

Updated by Jose 2 months ago

Hi Rafael,

I got a question about of SLA, which one option of support is that we have standard or enhanced.

Best regards

#20

Updated by MidVision 2 months ago

Hi Jose,

According to our records you are entitled to 'Standard' support, which is the default support you get when using one of our AMI's from the marketplace. 'Enhanced' support options are available here: [[https://www.midvisioncloud.com/support-services/enhanced-support/]]

Hopefully this answers your question.

Best Regards,
The MidVision Team

#21

Updated by Jose 2 months ago

Good morning,

I hope you are well.

Do you have any advance on this case?

Best regards

#22

Updated by Rafael 2 months ago

Hola, Jose:

We've given the maximum priority possible on the Red Hat support portal, but haven't received any news from the engineering team yet.

We're really trying hard on our side to give you the best help possible, I'll keep you posted with any update we get from Red Hat.

¡Saludos!

Rafa

#23

Updated by Rafael about 2 months ago

Hola, Jose:

A new update from the Red Hat team:

Hi,

We are still waiting for the feedback from our engineering team. We will keep you updated.

When are you planning to release of the project in production?

Thanks in advance.

Best Regards,
Oscar
Red Hat Support Team

¡Saludos!

Rafa

#24

Updated by Jose about 2 months ago

Hi Rafael,

I hope you are well.

Do you have any update of the case.

Best regards

#25

Updated by Mariusz about 2 months ago

  • Assignee changed from Red Hat Support to Jose

Hi,
No update from Red Hat I am afraid.
As Oscar asked - could you let us know when you are planning to release of the project in production?
Thanks,
Mariusz

#26

Updated by Jose about 2 months ago

Hi Midvision Support Team,

Do you have any update about this case?

Best regards

#27

Updated by Mariusz about 2 months ago

Hi,
No update from Red Hat I am afraid.
Could you let us know when you are planning to release of the project in production?
Thanks,
Mariusz

#28

Updated by Mariusz about 2 months ago

More information from Red Hat:

Hi,

After discussing with our team and running some tests, we found that it is working fine from the RHPAM 7.10.1. We suspect that it is related with a couple of bugs RHPAM-3449 / RHPAM-3458 which have been fixed on RHPAM 7.10.1. Could you update your application and let us know if it works in your installation as well, please?

Thanks in advance.

Best Regards,
Oscar
Red Hat Support Team
Hi,

If you want to update RHPAM 7.10.0 to 7.10.1, you have to download the Red Hat Process Automation Manager [VERSION] Update Tool [1] and follow the instruction in the documentation [2].

Let me know if it worked for you.

Thanks in advance.

[1] https://access.redhat.com/jbossnetwork/restricted/softwareDetail.html?softwareId=96061&product=rhpam&version=7.10.1&downloadType=patches
[2] https://access.redhat.com/documentation/en-us/red_hat_process_automation_manager/7.10/html-single/installing_and_configuring_red_hat_process_automation_manager/index#patches-applying-proc_patching-upgrading

Best Regards,
Oscar
Red Hat Support Team
#29

Updated by Jose about 2 months ago

Hi Oscar,

Thank you for the reply.

I got a question, do you have any AMI on the marketplace for this solution?

Best regards,

#30

Updated by Rafael about 2 months ago

Hola, Jose:

We don't currently have this particular version (7.10.1) published on the AWS Marketplace. We are in the process of publishing a new version but that will need some time to create and test the new AMI and a few days that the AWS Marketplace team usually takes to validate the publishing.

To upgrade an existing instance with the instructions on the previous ticket update is definitely quicker and should work straightaway.

¡Saludos!

Rafa

#31

Updated by Mariusz about 1 month ago

Hi,

Were you able to upgrade RHPAM and test the new version against the problem you were experiencing?
I can confirm we already submitted a new version and we are waiting for AWS Marketplace team to make it publicly available.

Regards,
Mariusz

#32

Updated by Mariusz about 1 month ago

  • Status changed from Feedback to Marked for Closure

RedHat support team archived the issue:

Hello,

It has been 10 days since our last attempt to reach you regarding this case. As we have not received a response, your case will be archived, but will be reopened if/when you contact us or update the case comments.

We hope your issue is resolved and hope you had a pleasant support experience.

Regards,
Red Hat Customer Experience and Engagement

#33

Updated by Jose about 1 month ago

Hi Midvision Team,

I hope you are well.

The solution of update RHPAM works fine.

Please, just let me know when the official release for fix this issue be published on the market.

Best regards,

#34

Updated by Rafael about 1 month ago

  • Status changed from Marked for Closure to In Progress
  • Assignee changed from Jose to Mariusz
  • Priority changed from High to Normal

Hola, Jose:

Great news! :-)

We'll keep you posted on when the new upgraded AMI with Red Hat Automation Manager 7.10.1 is published.

¡Saludos!

Rafa

#35

Updated by Mariusz 27 days ago

  • Status changed from In Progress to Marked for Closure
  • Assignee changed from Mariusz to Jose

Hi,
I would like to inform you that new versions of Red Hat Process Automation Manager are now publicly available on AWS Marketplace https://aws.amazon.com/marketplace/pp/prodview-pgwdreaunqfom
Regards,
Mariusz

#36

Updated by Mariusz 13 days ago

  • Status changed from Marked for Closure to Closed

Also available in: Atom PDF