Project

General

Profile

Support #3594

Problems with new version

Added by Vadim 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
RapidDeploy - 5.0-FIX
Start date:
07/16/2020
Due date:
% Done:

0%

Estimated time:
Affects Version:
RapidDeploy - 5.0-FIX
Timesheet Code:
Additional version details:
5.0.22

Description

Hello.

I was very glad to update our RapidDeploy to 5.0.21 version. :) But... Seems that something is wrong with it.
1. I already wrote this in ticket about project copying (Feature #3587). Data dictionary resources that are configured in system and are assigned to projects are not listed in those projects nor in assigned resources neither in available (please see screenshots).
2. Some projects just disappeared from project list. I didn't remove them before or after the update, they do exist on a disk, but they are not listed in RD.
3. Jenkins cannot invoke fully configured job plan with error "Job Plan has late configuration remain to be configured!" while that job plan can be run manually from WEB UI without any changes. I'm not sure if that's not a Jenkins' plugin problem, but want to put it here. :)

So seems that I have to rollback to previous version. Unfortunately. Can You please check these issues? If You need any additional data - just let me know. We can also have a call to check all these things online (I'll save current docker image for testing).

Best regards,
Vadim.


Files

firefox_PM7xHjHX0Y.png (52 KB) firefox_PM7xHjHX0Y.png Vadim, 07/16/2020 10:25 AM
firefox_mpAmHNoG6f.png (70.4 KB) firefox_mpAmHNoG6f.png Vadim, 07/16/2020 10:25 AM
#1

Updated by MidVision 6 months ago

  • Assignee set to Mariano
  • Priority changed from Normal to High
#2

Updated by Rafael 6 months ago

  • Status changed from New to Feedback
  • Assignee changed from Mariano to Vadim
  • Target version set to 5.0-FIX

Hi Vadim,

Are you available to hold a call and go through this problem?

I'm available right now, but let me know your availability and I'll send you an invite.

Cheers!

Rafa

#3

Updated by Vadim 6 months ago

Hi Rafael.

I'm at my workplace now. We definitely can have a call. :)

Best regards,
Vadim.

#4

Updated by Rafael 6 months ago

Hi Vadim,

I'll send you an invite by email.

Cheers!

Rafa

#5

Updated by Rafael 6 months ago

  • Assignee changed from Vadim to Mariano
  • Priority changed from High to Normal

Hi Vadim,

I'm glad we resolved the first two points, we will be discussing about the third one.

We'll keep you posted! :-)

Cheers!

Rafa

#6

Updated by Rafael 6 months ago

Hi Vadim,

For the records:

Point one was about the different location of resources.

And point two was about not selecting the "remove files" from the project "SCM Repository" tab in the project configuration page.

Please state here any other conclusion you took from our conversation! :-)

Cheers!

Rafa

#7

Updated by Rafael 6 months ago

  • Status changed from Feedback to In Progress

Hi Vadim,

We've identified and reproduced what's probably one of the strangest problems I have ever seen in programming, the point 3.

It doesn't seem to be with the job plans but with the projects the job plan is using, apparently if you change something in a project, the change is detected immediately by the graphical interface call, but the web service call doesn't pick this change until you change something in the job plan.

Although we could reproduce it quite a few times, it is quite random as well, some times it was just working fine.

We are suspecting there could be some kind of cache in the database that's not showing the changes straight away to the web service, but that's extremely strange as the web service and the graphical interface use the same background code! :-S

Anyway, we're going to be working on this and will keep you posted with any update.

Thank you so much for all your feedback! :-)

Cheers!

Rafa

#8

Updated by Mariano 6 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Mariano to Rafael

Hey Rafa,

I checked in some fixes, please update your workspace and test this again. This fix will be available in next release 5.0.22.

Cheers,
MP

#9

Updated by Rafael 6 months ago

  • Assignee changed from Rafael to Vadim
  • Additional version details set to 5.0.22

It looks great Mariano! :-)

Ready for relase 5.0.22 of RapidDeploy!

Vadim, we'll let you know when the new version is out, please let us know if this is still a problem.

Thanks!

Rafa

#10

Updated by Rafael 5 months ago

  • Status changed from Resolved to Marked for Closure

Hi Vadim,

This fix was already released on version 5.0.22 of RapidDeploy, if you don't have anything else to add we'll close this ticket in a few days time.

Cheers!

Rafa

#11

Updated by Rafael 5 months ago

  • Status changed from Marked for Closure to Closed

Also available in: Atom PDF