Project

General

Profile

Image Support #3056

IBM MQ menu not working properly

Added by Teramoto over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Due date:
02/08/2018
% Done:

0%

Operating System:
Linux
JRE:
Not Applicable
Instance Type:
m3.medium
Your Marketplace Account ID:
8775-6891-1829
Marketplace:
Amazon Web Services
Customer State:
Tokyo
Customer Country:
Japan

Description

Today I deployed IBM MQ v 9.0.3.0 on AWS Tokyo region.
Then I tried to configure IBM MQ by the menu.
So I made Queue Managers, but I could not make Listeners, Queues, Channels by the menu.

Manage Queues for QM
====================
Please select from list
 1. Define new Local Queue for QM: QMGRA
 2. Define new Transmition Queue for QM: QMGRA
 3. Empty Local Queue for QM: QMGRA
 4. Delete Local Queue for QM: QMGRA
 5. Define new Remote Queue for QM: QMGRA
 6. Delete Remote Queue for QM: QMGRA
 7. Define new Model Queue for QM: QMGRA
 8. Delete Model Queue for QM: QMGRA
 9. Display Local Queues for QM: QMGRA
 10. Display Remote Queues for QM: QMGRA
 x. Quit
>1
defineLocalQueue valid selection
Define new Local Queue
Please provide the name of new Local Queue ...
test
sed: -e expression #1, char 0: no previous regular expression
5724-H72 (C) Copyright IBM Corp. 1994, 2017.
Starting MQSC for queue manager QMGRA.

No MQSC commands read.
No commands have a syntax error.
All valid MQSC commands were processed.
Hit any key to return to Main menu>

Files

menu.sh (34.5 KB) menu.sh Mariusz, 02/07/2018 01:09 PM
wmq_def_scripts.zip (13 KB) wmq_def_scripts.zip Mariusz, 02/08/2018 11:27 AM
mqm-home.tar.gz (7.92 KB) mqm-home.tar.gz Mariusz, 03/12/2018 01:13 PM
#1

Updated by Mariusz over 3 years ago

  • Assignee changed from MidVision Cloud Support to Mariusz
#2

Updated by Mariusz over 3 years ago

  • Status changed from New to In Progress
#3

Updated by Mariusz over 3 years ago

  • File menu.sh menu.sh added
  • Status changed from In Progress to Feedback
  • Assignee changed from Mariusz to Teramoto

Hi Teramoto,
We were able to reproduce your problem. It turned out our menu.sh script got corrupted in our publishing process so in new 9.0.3.0 version of MQ product this script has some errors.
We will re-publish AMI soon.

At the moment in order to work with the current version - please replace the content of /home/midvision/menu.sh with the one I attached to this ticket.

I will let you know when the new AMI with fixed menu.sh script is available.

It is worth to mention that our simple tool helps you to create basic MQ configuration (it doesn't support all the properties you can set for QM, Queue, Listener etc).
If you need to create more advanced configurations please follow the IBM documentation : https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_9.0.0/com.ibm.mq.con.doc/q015120_.htm

Regards,
Mariusz Chwalek

#4

Updated by Teramoto over 3 years ago

Hi Mariusz,

Thank you for your sending a new version of menu.sh.
Then I tried to replace /home/mqm/menu.sh with it.
But I could not define a new listener.

Manage Listeners for QM
=======================
Please select from list
 1. Define new listener for : QMGRA
 2. Delete listener for : QMGRA
 3. Start listener for : QMGRA
 4. Stop listener for : QMGRA
 5. Display listeners status for QM: QMGRA
 x. Quit
>1
defineList valid selection
Define new listener
Please provide the name of new Listener ...
test
Please provide the port of new Listener ...
1415
5724-H72 (C) Copyright IBM Corp. 1994, 2017.
Starting MQSC for queue manager QMGRA.

     1 : DEFINE LISTENER () +
       : TRPTYPE (TCP) +
       : PORT (mvadmin) +
       : CONTROL(QMGR)
AMQ8405: Syntax error detected at or near end of command segment below:-
DEFINE LISTENER ()

AMQ8427: Valid syntax for the MQSC command:

  DEFINE LISTENER( listener_name )
   TRPTYPE( TCP )
     2 : END
One MQSC command read.
One command has a syntax error.
All valid MQSC commands were processed.
Hit any key to return to Main menu>

So I checked a code of menu.sh. Then I found a mistake of a template file "wmq_def_scripts/define_listener.in".
The script (menu.sh) will replace a word "LISTENER_NAME" in the template file, but the word does not include in that file.

$ cat wmq_def_scripts/define_listener.in
DEFINE LISTENER () +
TRPTYPE (TCP) +
PORT (mvadmin) +
CONTROL(QMGR)
END

Would you please send me fixed template files?

#5

Updated by Mariusz over 3 years ago

  • Assignee changed from Teramoto to Mariusz
#6

Updated by Mariusz over 3 years ago

Hi Teramoto,

You are right, not only menu.sh script has errors but also files from wmq_def_scripts folder.
Please remove this folder and unzip attached file to your /home/mqm directory.

We found the reason of this problem and we will republish an AMI in a few days.

Regards,
Mariusz Chwalek

#7

Updated by Teramoto over 3 years ago

Hi Mariusz,

Thanks for files of wmq_def_scripts!
At last I could defile a new Queue. Then I will try to define other objects.

We found the reason of this problem and we will republish an AMI in a few days.

Would you tell me the changes about new AMI, because I want to keep using current AMI.
If you have any other changes, please send me files about the changes.

Log (define new queue)

Manage Queues for QM
====================
Please select from list
 1. Define new Local Queue for QM: QMGRA
 2. Define new Transmition Queue for QM: QMGRA
 3. Empty Local Queue for QM: QMGRA
 4. Delete Local Queue for QM: QMGRA
 5. Define new Remote Queue for QM: QMGRA
 6. Delete Remote Queue for QM: QMGRA
 7. Define new Model Queue for QM: QMGRA
 8. Delete Model Queue for QM: QMGRA
 9. Display Local Queues for QM: QMGRA
 10. Display Remote Queues for QM: QMGRA
 x. Quit
>2
defineTransmitionQueue valid selection
Define new Transmission Queue
Please provide the name of new Transmission Queue ...
QMGRB.XMIT.DF
Please provide the local name of the initiation queue on this queue manager, to which trigger messages relating to this queue are written.
SYSTEM.CHANNEL.INITQ
5724-H72 (C) Copyright IBM Corp. 1994, 2017.
Starting MQSC for queue manager QMGRA.

     1 : DEFINE QLOCAL(QMGRB.XMIT.DF) +
       : REPLACE +
       : USAGE(XMITQ) +
       : PUT(ENABLED) +
       : GET(ENABLED) +
       : TRIGGER +
       : TRIGTYPE(FIRST) +
       : INITQ(SYSTEM.CHANNEL.INITQ)
AMQ8006: IBM MQ queue created.
     2 : END
One MQSC command read.
No commands have a syntax error.
All valid MQSC commands were processed.
Hit any key to return to Main menu>

#8

Updated by Mariusz over 3 years ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Teramoto to Mariusz

Hi Teramoto,

The problem was lying (as you noticed ) in menu.sh script and other files from wmq_def_scripts folder.
Our publishing process was configured incorrectly and all the entries with the @@ were incorrectly replaced with empty string.
You have all of the necessary changes now so you can keep using this AMI.

Nevertheless I will update this ticket when the AMI is published.

Regards,
Mariusz Chwalek

#9

Updated by Teramoto over 3 years ago

Hi Mariusz,

You have all of the necessary changes now so you can keep using this AMI.

I understand. I continue to use the current AMI that replaced menu.sh and template files.

Nevertheless I will update this ticket when the AMI is published.

I'm looking forward to your reply.

Regards,
Hirohisa Teramoto

#10

Updated by Mariusz over 3 years ago

Hi,

I would like to let you know that new version of IBM MQ (9.0.4.0) is now available on AWS marketplace https://aws.amazon.com/marketplace/pp/B06XD2FW9Q
This new AMI contains a fix for our initial scripts.
As I mentioned in one of my previous comments - you can still keep using your current instance.
I am also attaching a package containing the newest version of menu.sh script and other files (just to make sure you have all the latest fixes).

Thanks,
Mariusz

#11

Updated by Teramoto over 3 years ago

Hi Mariusz,

Thanks for your reply.
I acknowledged that the new version has been released and includes fixes.

Best regards,
Hirohisa Teramoto

#12

Updated by Rafael over 3 years ago

  • Status changed from Marked for Closure to Closed

Hi Hirohisa,

Following your confirmation, I'm closing this ticket. Please don't hesitate to open a new ticket if you find any future issue.

Kind regards,

Rafa

Also available in: Atom PDF